
Sente
Version 4

User’s Guide

Third Street Software, Inc.



Copyright © 2006 Third Street Software, Inc.

All Rights Reserved

Mac OS is a registered trademark of Apple Computer, Inc.

Microsoft is a registered trademark of Microsoft Corporation in the 
United States and other countries.

EndNote is a registered trademark of The Thomson Corporation.

Produced August 2006



Contents

................................................................................1 • Overview 7
...................................................................................What is Sente? 7

.................................................................................New in Version 4 8

.................................................................................New in Version 3 9

.........................................................2 • Installation & Support 11
.......................................................................System Requirements 11

....................................................................................How to Install  11
................................................................Authorizing Your Copy 11

...........................................Upgrading from a Previous Version 11
..........................Moving Your Authorization to a New Computer 12

...................................................................Plugin Configuration 12
.........................................................................Support & Upgrades 13

.............................................................3 • Viewing References 15
...........................................................About Your Reference Library 15

...............................................................................Reference Table 16
.............................................................................................Browser 18

..................................................................................Details Drawer 20
............................................................................................Find Box 21

........................................................................................View Menu 22
............................................................................................Spotlight 23

.........................................4 • Editing & Annotating References 25
........................................................About Reference File Structure 25

...............................................................................Reference Editor 25
..............................................................................Citation Pane 26
.............................................................................Abstract Pane 27

................................................................................Notes Pane 28
............................................................................Details Drawer 29

Fields
Keywords
Links
Identifiers

.................................................................Multiple Reference Editor 33
.....................................Annotating References in the Main Window 34

...................................................................Assigning Keywords 34
...........................................................Setting Viewed Indicators 35

.........................................................................Setting Statuses 35
...........................................................................Setting Ratings 35

..............................................................................Adding Notes 36
........................................................................................Linking 36

....................................................Automated Reference Processing 37
.........................................................................Deleting References 37

................................................................................Saving Changes 37

3



.................................5 • Retrieving & Managing Full Text Files 39
...................................................................................Creating Links 39

......................................................Managing Linked Files Manually 40
...............................................Automating Linked File Management 40

...................................Modifying Link Management Parameters 42
.............................................................................Full Text Retrieval 42

.................................................Performing a Full Text Retrieval 43

...............................................................................6 • Searches 45
.............................................................................PubMed Searches 45

..................................................Setting Up Advanced Searches 46
..........................................................................Viewing Results 47

...............................................................................Z39.50 Searches 48
..............................................Configuring Z39.50 Data Sources 49
..............................................Editing Searches (PubMed & Z39.50) 51

...........................................Updating Searches (PubMed & Z39.50) 51
..........................................Managing Searches in the Library Pane 52
...........................................Deleting References from Searches 52

..............................................Setting Up Functional Hierarchies 52

...................................................................................7 • Filters 53
..................................................................................Creating Filters 53

.....................................................................Filter Refresh Behavior 54
....................................................................................Editing Filters 54

..................................................................................Copying Filters 54
................................................Managing Filters in the Library Pane 54

...........................................................................Deleting Filters 54

............................................................................8 • Collections 57
..........................................................................Creating Collections 57

.....................................................Adding References to Collections 57
...........................................................Adding Folders to Collections 57

........................................Managing Collections in the Library Pane 58
....................................................................Deleting Collections 58

...............................................................Creating a New Reference 59

......................................................................9 • Bibliographies 61
.....................................................................Creating Bibliographies 61

..........................................10 • Microsoft Word Bibliographies 65
.........................................................................Activating the Plugin 66

......................................................................................Sente Menu 66
..................................................Inserting Citations & Bibliographies 67

Deleting a Citation
................................................Selecting a Bibliography Format 67

Modifying a Format in Use

4



......................Controlling Character and Paragraph Formatting 68
....................Editing Citations and Bibliography Entries Directly 68

Editing Citations
Editing Bibliography Entries

.............................................11 • RedleX Mellel Bibliographies 71
................................................................Enabling the Mellel Plugin 71

...............................................Inserting Citations and Bibliographies 72
............................................................Editing Inserted Citations 74

..........................12 • Custom Citation & Bibliography Formats 75
.................................................Constructing a Bibliography Format 75

.............................................................................General Pane 77
Order bib. by:
Tag style in bib:
In-Text Citations
Rich Text Format

.........................................................Bibliography Entries Pane 79
Setting up the Element Sequence
Viewing Sample Output
Configuring Each Element
Configuring Other Reference Types

..........................................................................Advanced Pane 83
..........................................................Sharing Your Custom Formats 83
........................................................Downloading New Formats 83

......................................13 • Automated Reference Processing 85
...............................................................Custom Processing Scripts 85

.....................................14 • Importing, Exporting and Printing 87
..................................................................................Importing Data 87
..................................................................................Exporting Data 88

................................................................Drag and Drop Export 88
.............................................................................................Printing 89

..............................................................15 • Configuring Sente 91
.......................................................................... Customize Window 91

...................................................................................Ref Types 91
...................................................................................Ref Status 92

..........................................................................................Fields 93
....................................................................................Keywords 94
...................................................................................Auto Links 95

........................................................................ Appearance Window 96
.........................................................................Reference Table 96

...........................................................................................Fonts 97
....................................................................... Bibliography Window 98

...............................................................................Drag & Drop 98
.........................................................................................Mellel 98

5



....................................................................................MS Word 99
.................................................................................Title Case 100

............................................................................. Plugins Window 101
Installing Additional Plugins

................................................................................... Link Window 102
......................................................................... Advanced Window 103

...................................................................... Registration Window 104
............................................................................................Toolbar 105

...................................................................................Journal Titles 105

...............................................Appendix • Keyboard Shortcuts 106
....................................................Customizing Keyboard Shortcuts 107

6



1 • Overview

What is Sente?
Sente helps you keep up with the literature. Through its intuitive 
interface Sente provides unique organizational tools that make it easy to 
pinpoint the information you need—even if you've collected thousands 
of references. With Sente you can search hundreds of the most important 
academic literature databases on the Internet. Sente then scans for new 
information every day to keep you up to date on all of your research 
topics.

Sente also allows you to edit and annotate your references, link them to 
your PDF collection, share data with colleagues who use other formats, 
and generate formatted bibliographies in your manuscripts.

Sente (pronounced SEHN-tay) is a Japanese word used in the game of 
GO. If you have sente, it means your moves are controlling the game, 
keeping you a step ahead of your opponent. Likewise, if you’re often 
feeling “behind” the literature, Sente software helps you take control and 
stay on top of a rapidly changing information universe.
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Sente gives you the ability to:

• Search for references in hundreds of online literature databases

• Automatically keep your search results up to date

• Review your references quickly and easily

• Organize collections of references to support your research, using 
tools like custom keywords, statuses, and ratings

• Employ sophisticated filtering to track and locate the references you 
need

• Enter & edit references manually to add information not available on 
line 

• Annotate any reference with your own research notes

• Automatically locate and download full text files, when available

• Link references to full text files and organize your PDF collections 

• Import and export reference data in a variety of formats to share with 
colleagues or use in other software

• Generate bibliographies that meet the needs of particular journals

• Customize bibliography formats to meet your own needs

• Generate formatted citations and bibliographies automatically within 
Microsoft® Word and RedleX Mellel (using features similar to 
EndNote® Cite While You Write).

New in Version 4
• Full Text Retrieval—Sente can automatically locate, download, link, 

and organize full text files when the articles are readily available on 
line or on a local disk. Sente can search for files using the Digital 
Object Identifier, PubMed LinkOut, Google, and Spotlight.

• Amazon Cover Art Retrieval—Sente can automatically download 
and attach cover art for books and other materials with cover art 
available at Amazon.com.

• Custom Reference Processing Scripts—You can create menu 
commands that apply a specified, ordered series of actions to selected 
references (such as multiple methods of full text retrieval). 

Sente 4.0
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• Enhanced Linked File Management—Sente can now update the file 
naming and organization of any previously managed files whenever 
you change your management criteria. 

• Enhanced Import/Export—We have added TaggedRecord to Sente’s 
import capabilities and EndNote 9 to to Sente’s export capabilities.

New in Version 3
• Universal Binary—Sente is coded as a universal binary, meaning it 

runs natively on both PowerPC and Intel-based Macs (OS X 10.4 is 
now required).

• Spotlight Aware—References are indexed for Spotlight searching 
from the Mac OS Finder; you can double-click a reference in Spotlight 
to open it in Sente.

• New Plugin Architecture—Many of Sente’s key features are enabled 
through plugins. This increases our ability to incorporate new 
features in the future.

• Ratings—You can assign a rating of one to five stars to a reference 
and filter on rating criteria.

• Status—You can create and assign custom statuses to your references 
and organize your references based on status criteria. You can also 
assign status-based text colors that appear in the reference table.

• Multiple Links—You can annotate a reference with any number of 
hyperlinks pointing to web pages and to local files. 

• Linked File Preview—If you’ve linked a PDF or other file to a 
reference, you can see a first-page preview in the Details Drawer.

• Linked File Management—Sente can copy, rename, and store your 
linked files automatically according to criteria you choose.

• Enhanced Bibliography Formats—We have added some new 
bibliography formats and have enhanced the Format Editor.

• Enhanced Import/Export—We have added BibTeX, Refer (Generic), 
and Refer (EndNote) to Sente’s import capabilities; we have added 
BibTeX (Unicode) to Sente’s export capabilities.

• Enhanced Word Citations—If you manually edit citations inserted in 
a Microsoft Word document, your changes are retained after a 
document refresh. 

1: Overview
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• Redesigned Reference Editor—We have given the Reference Editor a 
major face lift to make it easier to manage reference information.

• Streamlined Preferences—A new preferences window makes it 
easier to configure Sente to your needs.

• Master Reference File Structure—Sente maintains a single master file 
for each reference to ensure consistency throughout your reference 
library.

Sente 4.0
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2 • Installation & Support

System Requirements
Sente requires Mac OS X 10.4 (Tiger) or higher and an internet 
connection. Sente is a universal binary, running natively on both 
PowerPC and Intel-based Macintosh computers. Extra RAM above that 
required for OS X can improve performance when handling very large 
reference libraries. 

The Microsoft Word plugin requires Word X or Word 2004. The RedleX 
Mellel plugin requires Mellel 1.9.1 or higher; learn about the Mellel word 
processor at www.redlers.com. 

How to Install
Download Sente from www.ThirdStreetSoftware.com as a self-mounting 
disk image (.dmg) file. If necessary, double-click the file to mount the 
image. Then simply drag the Sente application file to your Applications 
folder. 

Authorizing Your Copy
Sente runs in authorized mode or as a demo. If you purchased Sente on 
line from ThirdStreetSoftware.com, enter your Order Code when you 
launch Sente; if you purchased Sente from a retail store, enter the License 
Key included in the box. In either case, you’ll need an active internet 
connection for Sente to validate your Order Code or License Key and 
authorize itself on your computer. 

If you have not yet purchased Sente, it will run unrestricted for 30 days; 
after that Sente will not run without authorization.

Upgrading from a Previous Version
If you have a previous version of Sente installed, simply replace the old 
version with the Sente application file. 

Sente may use a different data format than previous versions. When you 
run a new version for the first time, Sente may take several minutes to 
migrate your existing reference data. Once the migration is complete, 
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earlier versions of Sente will not be able to access your reference data. 
For safety, you should back up your reference library (~/Library/Sente if 
you haven’t moved it) and your preferences file (~Library/Preferences/
Sente.plist) before upgrading.

Moving Your Authorization to a New Computer
Your Order Code or License Key will allow you to authorize Sente on a 
certain number of computers, depending on the type of license you 
purchased. To move your authorization from one computer to another, 
you may need to de-authorize your old computer by selecting 
Sente>Sente Preferences>Registration and clicking the De-authorize 
button. Then launch Sente on your new computer and enter your 
original Order Code or License Key. 

Plugin Configuration
Sente ships with a default set 
of plugins that provide data 
source access, word 
processor integration, and 
data converters used for 
import and export—all of 
which are documented in 
this User’s Guide. If you’ve 
installed additional plugins, 
please see the documentation 
that came with the plugin. 

To view the list of installed 
plugins from the Finder, 
select the Sente application 
icon and choose File>Get 
Info. You can also see this list 
in the Plugins window in 
Sente’s Preferences.

The Plug-ins section of the 
Info window also allows you 
to add plugins you have 
downloaded.

Sente 4.0
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Support & Upgrades
Sente will let you know whenever a new version of itself is available for 
download. 

If you have a question or would like to suggest ways to improve Sente, 
visit www.ThirdStreetSoftware.com; there you’ll also find discussion 
forums with additional information, downloads (bibliography formats 
and plugins), and usage tips.

2: Installation & Support
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3 • Viewing References

Use Sente’s main window to browse your reference library via the 
Library Pane, Reference Table, Browser, and Details Drawer. Sente comes 
with a sample reference library preloaded; we recommend you use this 
data to familiarize yourself with Sente’s features. 

If you’d like to increase the font size used in the main 
window, you can do so in the Appearance window in 
Sente’s preferences. See Fonts in Chapter 15.

About Your Reference Library
Sente organizes your reference library using four kinds of folders, each 
with a specific function and some rules to govern its behavior. Chapters 
6-8 discuss these folder types in detail, but it’s helpful to understand 
what they do before diving into Sente.

A Search (Chapter 6) is a folder that contains references from 
an online database that match a set of search criteria. Each 
Search can represent a different set of search criteria.

A Filter (Chapter 7) is a folder that derives its contents from its 
parent folder based on a set of refining criteria.

A Collection (Chapter 8) is a folder where you control the 
contents manually; Collections help you organize your library 
and allow you to arrange Filters in ways that increase their 
flexibility.

A Bibliography (Chapter 9) is a folder that allows you to control 
the reference order for generating rich text bibliographies within 
Sente.

You can organize your library into nested hierarchies that help you make 
the most of these folder types. See Chapters 6-9 for examples. 
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Reference Table
Whenever you select a folder in the Library pane, the references it 
contains appear in the Reference Table.

An orange dot  indicates you haven’t yet viewed the reference; click the 
leftmost column heading to sort the table by viewed indicator. Use the 
spacebar to move to the next unviewed reference in the table.

If you see a document icon , that means the reference is linked to an 
external file or web page; when the icon contains a PDF logo  , that 
indicates the reference is most likely linked to a local copy of the full text 
article. Double-click the document icon to view the linked resource (or 
shift-command-F). If the reference contains multiple links, only the 
default link will open—you can choose the default link in the Reference 
Editor (see Chapter 4).

The Reference Table also indicates whether the reference includes an 
abstract  and attached Notes . References that have been assigned a 
Status (see Setting Statuses in Chapter 4) may also appear as colored text.

Click any column heading to change the list order (scroll right to see 
more columns).

Sente 4.0
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You can configure Sente’s preferences to show and 
hide any table columns. For example, you can choose 
to show a Ratings column so that you’ll be able to use 

Rating as an ordering criterion. See Reference Table in 
Chapter 15.

3: Viewing References
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Browser
If you have hundreds of references in a library folder, Sente 
can help you fish out the ones you want through its powerful 
Browser—click Browser on the toolbar to show and hide it 
above the Reference Table. The Browser shows, for example, 
all of the Keywords found within the contents of the 

Reference Table.

Select any combination of Publications, Years, Authors, and Keywords to 
pare down the Reference Table to a manageable size. command-click to 
select multiple items in a list. As you select these filtering terms, they 
appear in a row above the Browser; click any term in this row to back up 
to that point, or click Clear to start over.

Sente 4.0
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To select entries in the browser list using the keyboard, click on one of 
the four column headings and then type the first few characters of what 
you're looking for. In the following example, you would click once on 
Keywords, then type heart; Sente automatically selects all keywords 
beginning with those letters.

3: Viewing References
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Details Drawer
Select a single reference in the Reference Table to view its 
contents in the Details Drawer. This drawer extends from the 
side of the main window; click Details on the toolbar to 
show and hide it. 

The Summary pane shows the reference’s Status, Rating, citation, article 
title, authors, and abstract. 

If the selected reference is linked to a local file (it will have a document 
icon in the Reference Table), the Preview pane in the lower part of the 
Details Drawer will display a thumbnail of the default linked 

Sente 4.0

20



document’s first page (for file types that do not support this feature, or if 
the default linked item is a web page, the the Preview pane will say 
Default attachment is not previewable). The Preview pane may also display 
cover art from Amazon.com if the Locate Cover Art reference processor 
was applied to the reference (see Chapter 13 - Automated Reference 
Processing). Double-click a thumbnail to open the linked file. You can 
hide the Preview pane by dragging the resize bar down to the bottom of 
the Details Drawer. See Chapter 5 - Retrieving & Managing Full Text Files 
for more information about linking references to files and web pages.

The Keywords and Notes panes let you view any keywords, keyphrases, 
and text notes that have been appended to the reference. See Annotating 
References in the Main Window in Chapter 4 for information on using the 
Details Drawer to edit Keywords and Notes.

Find Box
You can also use the Find box on the toolbar to search the contents of the 
Reference Table, including any Notes attached to your references (see 
Adding Notes in Chapter 4). Sente will dynamically pare down the list as 
you type, leaving only references that contain your string of characters. If 
you have the summary information for a matching reference displayed 
in the Details Drawer, Sente will highlight all of the matching search 
terms.

3: Viewing References
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View Menu
Select View>Link to access all linked resources (web pages and local 
files) for the selected reference. For example, PubMed records usually 
contain automatically generated external links that become accessible 
from this menu. If you’ve created your own links to files or web pages 
(see Linking in Chapter 4), these will also appear.

You can teach Sente to automatically generate external 
links for other kinds of records, such as those derived 
from a Z39.50 data source (see Auto Links in 

Chapter 15).

Sente 4.0
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Spotlight
Sente reference libraries are indexed for Spotlight searching within Mac 
OS X. To perform a Spotlight search, press option-command-
spacebar to bring up the Spotlight window and enter search terms. 
Click the info icon for a Sente reference to show details such as 
keywords, and double-click a reference to open it in Sente.

You can also click the 
Spotlight icon at the 
upper right corner of 
your screen and select a 
reference from the 
menu to open it in 
Sente.

Although OS X also 
allows you to perform 
Spotlight searches from 
a Finder window, we 
do not recommend this 
approach because 
Finder windows will 
not display descriptive 
file names.

3: Viewing References
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4 • Editing & Annotating 
References

Sente allows you to edit any reference data, and it remembers 
those edits even after it automatically updates your reference 
library. You can also annotate references with your own 
keywords, statuses, ratings, formatted notes, and hyperlinks 
to web pages and local files. 

About Reference File Structure
Sente maintains only one physical copy of each reference in your library, 
even when the reference appears in multiple places (such as in a Search 
and a Filter); therefore when you modify a reference from any location, 
your changes are reflected wherever that reference appears.

Reference Editor
To edit a single reference:

1. Select a folder in the Library pane and select the reference you want 
to edit (see Chapter 3 - Viewing References).

2. To open the Reference Editor: double-click the reference; or click Get 
Info on the toolbar; or select File>Get Info; or ctrl-click>Get 
Info.

3. Use the headings at the top of the Reference Editor to switch among 
information panes.
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Citation Pane

Click to the right of any field name to edit the field.

You can customize the Reference Type and Status 
menus; when you customize the Reference Editor, your 
changes become available for all references. See 

Customize Window in Chapter 15.

Sente 4.0
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Abstract Pane
The reference’s Abstract appears as editable plain text.

4: Editing & Annotating References
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Notes Pane
In the Notes pane you can paste any text and images. This pane provides 
TextEdit tools for formatting your Notes as rich text, and a spell checker 
is provided on the Edit menu.

Sente 4.0
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Details Drawer
Click Show/Hide Details in the Reference Editor to reveal a details 
drawer with Fields, Keywords, Links, and IDs panes.

Fields
If you have defined additional custom fields for the Reference Editor (see 
Fields in Chapter 15), you can enter and edit their values for the reference 
here. 

4: Editing & Annotating References
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Keywords
To modify an existing keyword or keyphrase manually, double-click the 
keyword. To add one of your own custom keywords, select it from the 
menu below the list and click the + button.

You can set up your own custom keywords and 
keyphrases to appear in this menu for all references 
(see Keywords in Chapter 15).

Sente 4.0
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Links
The links table indicates what files and/or web pages are linked to the 
reference. 

You can edit the link Name (this can be different from the name of the 
linked file), and—using the checkboxes—indicate whether a link is used 
to generate the URL element in a Bibliography (see Chapter 12 - Custom 
Citation & Bibliography Formats) and whether a link is used to generate 
the default preview (see Details Drawer in Chapter 3). 

Although it’s usually easier to drag a browser address field or a local file 
and drop it on the reference in the Reference Table, you can also create 
links by dragging and dropping onto the link table here, or by clicking 
the + button to select a local file. 

4: Editing & Annotating References
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Sente provides specialized tools for handling linked files—see 
Chapter 5 - Retrieving & Managing Full Text Files for more information.

Identifiers
In the Identifiers box you can add or modify identifiers used for 
generating automatic links (see Auto Links in Chapter 15).

Sente 4.0
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Multiple Reference Editor
You can make certain changes to multiple references at once. To edit 
multiple references, select at least two references in the Reference Table 
and click Get Info on the toolbar or select File>Get Info. 

You can apply edits to the Citation, Custom Fields (Other), Keywords, and 
Notes of all selected references. Only information shared by all selected 
references will appear in the fields; an empty field indicates no 
information is completely shared in that field.

If you enter any keywords or Notes, Sente will add them to existing 
Notes and keywords in the selected references.

4: Editing & Annotating References
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Only fields with their checkboxes checked will get changed in the 
selected references; you may uncheck a field if you change your mind 
about something, or you might check a blank field to clear the field in all 
references.

Annotating References in the Main 
Window
In Sente’s main window you can easily assign keywords, viewed 
indicators, statuses, and star ratings to multiple references using 
keyboard shortcuts and popup menus. You can also annotate single 
references in the Details Drawer.

Assigning Keywords
Sente provides a number of shortcuts that make it easy to assign 
frequently used keywords to references and edit existing keywords.

You can set up your own commonly used keywords and 
assign keyboard shortcuts to them (see Keywords in 
Chapter 15).

• Menus—Select one or more references and choose Edit>Assign 
Keyword or ctrl-click>Assign Keyword to assign a custom 
keyword to all selected references.

Sente 4.0
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• Keyboard—Select one or more references in the Reference Table (use 
shift-click or command–click to select multiple references) and 
enter a hotkey combination (e.g. command–1) to assign a custom 
keyword to all selected references.

• Details Drawer—Select one reference in the Reference Table and click 
Keywords in the Details Drawer. Choose one of your custom 
keywords from the menu at the bottom of the Details Drawer, then 
click + to add it to the selected reference (once added, you can 
double-click the keyword to edit).

Setting Viewed Indicators
To toggle the viewed indicator for one or more references, select the 
reference(s) in the Reference Table and ctrl-click on your selection to 
access Set to Viewed and Set to Not Viewed options in a popup menu. 
You can also find these options on the Edit menu. 

Setting Statuses
To set the Status for one or more references, select the reference(s) in the 
Reference Table and enter a hotkey number combined with 
option-command (enter option-command-0 to clear Statuses), 
ctrl-click to set Statuses from a context menu, or choose 
Edit>Assign Status. You can also set the Status for a single reference 
using the Status menu in the Summary pane of the Details Drawer.

You can choose your own Status names and color 
codes, and assign keyboard shortcuts for them (see 
Ref Status in Chapter 15).

Setting Ratings
To set the star 
Rating for one or 
more references, 
select the 
reference(s) in the 
Reference Table 
and enter the 
shortcut ctrl-
command-(0-5) to 
set the number of 
stars, ctrl-click to set Ratings from a context menu, or choose 

4: Editing & Annotating References
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Edit>My Rating. You can also rate references individually by clicking in 
the Rating field in the Summary pane of the Details Drawer.

Adding Notes
Using the Details Drawer, you can drag text and images and drop them 
into the Notes field. If you need formatting tools, use the Notes pane in 
the Reference Editor (see Reference Editor earlier in this chapter).

While creating or editing Notes, you'll find a spelling checker on the Edit 
menu.

Linking
To link a reference to a local file or to a web address, drag the file or the 
address (from your browser’s address bar) and drop it onto a reference 
in the Reference Table. 

You may also select a reference and then select Edit>Add Link... (or 
ctrl-click on the selection to access this command from a context 
menu) to create a link to a local file. Sente will remember the location of 
linked files even if they later get moved. Keep in mind that after you’ve 
dropped a file onto a reference, you won’t see it in the Preview pane of 
the Details Drawer unless you’ve also selected the reference in the 
Reference Table. 

You can use Sente to automate full text retrieval, file linking, and 
storage—see Chapter 5 - Retrieving & Managing Full Text Files for more 
information.

Sente 4.0
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Automated Reference Processing
Sente provides a variety of plugins to automate complex actions that can 
be applied to references in your library, such as full text retrieval (see 
Chapter 5 - Retrieving and Managing Full Text Files) and other additional 
data retrieval. These actions are accessible from the Edit>Perform 
submenu. See Chapter 13 - Automated Reference Processing for complete 
details.

Deleting References
You can manually delete a reference from a Search, Collection, or 
Bibliography folder. Select the reference(s) in the Reference Table and 
press command-delete. 

Deleting a reference comes with a few important caveats:

• If you delete a reference from a PubMed search, Sente will restore it to 
your Search if its record at PubMed gets updated.

• If you delete a reference from a Z39.50 search (i.e. not PubMed), it will 
reappear the next time Sente updates your search regardless of 
whether is has been updated at the data source; therefore it’s 
generally not useful to delete references from a Z39.50 search.

• You cannot delete references from a Filter (see Chapter 7 - Filters).

• Because Sente stores only one data file for each reference in your 
library—even when a reference appears in multiple folders—deleting 
one copy will not affect any other copies that may exist in your 
library.

Saving Changes
Sente saves your changes automatically as you work, so manual saves 
are usually unnecessary. However, if you make a significant run of 
changes—particularly to how references are organized within your 
library—you might want to choose File>Save All to safeguard your 
recent work in the event of a power loss.

4: Editing & Annotating References
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5 • Retrieving & Managing Full 
Text Files

Sente allows you to link any reference to a local file or web page that 
contains the full text article or other supplementary material for the 
reference. This provides easy access to linked material whenever you are 
viewing a reference. Sente can also search for and retrieve the full text file 
for any reference and link it to that reference. As files are linked, Sente 
can automatically rename and organize the linked files according to 
criteria you choose.

Creating Links
The simplest way to link a reference to a file is to download a file and 
drop it onto a reference in the Reference Table, as described in Linking in 
Chapter 4. You can create a link to a web page in the same way, by 
dragging the address from your browser’s address bar and dropping it 
onto a reference.
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Managing Linked Files Manually
You can move and rename previously linked files—the links you’ve 
created in Sente will remain unbroken. If you prefer to manage the files 
yourself, select Sente>Sente Preferences>Link and be sure the link 
management checkbox is unchecked.

Automating Linked File Management
If instead you would like Sente to automate file management, check the 
Sente should manage documents linked to reference checkbox to enable this 
feature. This will cause Sente to do the following every time you link a 
reference to a file:

• Create a copy of the file.

• Rename the copy using information derived from the linked reference 
(according to the naming format you’ve specified; see below).

• Store the copy within a folder structure you’ve specified, creating 
new folders as needed.

• For links to URLs that point directly to a file: automatically download 
the file and then rename and store it as described above.
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The Copy linked documents to: box shows the root folder where Sente will 
place all linked files. By default, linked files go into a folder called Sente 
within your Documents folder.

Sente can also organize your linked files into subfolders according to 
First Author Last Name, Article Title, Publication Title, and Year of 
Publication. In the example shown above, if you link a file to a reference 
for a 2004 article in the EMBO Journal, the file would get copied to 
~Documents/Sente/2004/EMBO J.

Sente will also rename the linked file according to the Bibliography 
Format you specify. Using a Bibliography Format for naming allows you 
to specify any element(s) of the linked reference to be used as the file 
name. The example above uses a simple Bibliography Format called First 
Author Surname, which contains only the Author element. In this case, 
your linked file might be renamed Abdalla SI.pdf.
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See Chapter 12 - Custom Citation & Bibliography Formats for information on 
setting up these formats.

Sente automatically creates subfolders 
as needed each time you link a file to a 
reference. If you wish, you can 
manually rearrange these folders—
Sente will still find the linked files even 
after you’ve moved them.

If you move or delete a Sente-generated 
subfolder, Sente will recreate it the next 
time you create a link that requires the 
subfolder.

Modifying Link Management 
Parameters
If you’ve enabled Sente’s link management feature and later decide to 
change the parameters in the Link preferences window, such as the 
subfolder structure or file naming format—or disable link management 
altogether—you can choose to have Sente update your existing file 
structure and naming conventions to reflect your new preferences by 
clicking Apply to Existing Linked Files. Otherwise, Sente will leave any 
existing automatically generated folders and files untouched such that 
your changes will only affect the links you create from that point 
forward. 

Full Text Retrieval
Sente can automatically find, download, and link the full text articles for 
any reference, assuming the file is readily accessible on the Internet or on 
a local disk.  

Note: Sente cannot download full text articles that 
require a subscription, fee, or other special access 
privileges unless your computer already has access to 
these resources. Sente may still be able to locate these 
articles.

Sente currently supports four different approaches for locating full text 
files, which will have different success rates depending on an article’s 
location and availability. These approaches are enabled via four 
reference-processing plugins:
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DOI/Handle—Many references include a standardized file locator code 
known as the Digital Object Identifier (see DOI.org for details). When 
performing full text retrieval, Sente finds the DOI in the reference (or if 
it’s missing, Sente will attempt to obtain it from the public DOI 
repository—crossref.org—and then add it to the reference) and then query 
an Open URL server for a path to the full text file. 

If you have access to a specific  Open URL server, such 
as one provided by your university library, you should 
configure the OpenURL  plugin to use that server (see 

Plugins Window in Chapter 15).

PubMed LinkOut—Although Sente automatically generates a link to the 
PubMed LinkOut web page for references that contain PubMed 
identifiers (see View Menu in Chapter 3), full text retrieval from PubMed 
automatically scans the LinkOut resource for appropriate links and then 
attempts to download the full text file.

Google—With this retrieval method, Sente executes a Google search 
based on data it extracts from the reference and then attempts to 
download the most likely candidate for a full text file.

To enable the Google plugin, you must first obtain a free 
personal license key from Google.com/apis. Then enter 
the key by configuring the Google full  text locator plugin 

in the Plugins Window (see Chapter 15).

Spotlight—If the full text file is stored on your hard drive or other local 
disk, Sente can find it by executing a search through Mac OS X’s 
Spotlight feature.

Performing a Full Text Retrieval
You can invoke one or a combination of several reference-processing 
actions (see Automated Reference Processing in Chapter 13) to attempt full-
text retrieval:

1. Select one or more references in the Reference Table.

2. Select Edit>Perform.
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3. Select a Locate full text command from the submenu.

Sente will begin searching in the background. The time to perform a full 
text retrieval varies with the number of references selected and with the 
chosen retrieval method. 

When Sente downloads a full text article (or finds it on your local hard 
drive), it creates a link to the file in the reference. It also renames and 
stores the file in accordance with your current file management 
preferences (see Automating Linked File Management earlier in this 
chapter). If you have not activated file management, Sente will place the 
file in your default download location (you can later manually move the 
file to a new location without breaking the link in the reference).

If Sente cannot download the file (for example, if the article requires a 
subscription or fee), Sente may instead link the reference to a web page 
that refers to the article.
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6 • Searches

The primary way to add references to Sente is by creating a 
Search. Upon executing a Search of an online data source, 
Sente downloads and stores the matching references in a 
Search folder. Sente also remembers the Search criteria so it 
can automatically keep the contents of the Search up to date 

with new references.

Sente version 3.0 includes two data source plugins: PubMed (MedLine) 
and Z39.50.

PubMed Searches
Click Search on the toolbar, or choose File>New Search. From the 
popup list, select PubMed.

The PubMed Search window allows you to search for or exclude terms 
from particular fields in the PubMed record. Use asterisks in your search 
terms to indicate wildcards.
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Setting Up Advanced Searches
The PubMed Search window also allows you to set up complex boolean 
Searches using all of and any of commands.

In the example shown above, Sente searches for references that include 
acetaminophen AND (ibuprofen OR diphenhydramine).
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Viewing Results
After you click Execute Search, Sente may report the number of 
references found and give you a chance to refine your search criteria 
before downloading the results.

By default Sente gives you the option—before 
downloading—to refine any Search whenever it returns 
at least 100 references; it also limits the size of very 

large results sets to protect against slowdowns. You can modify 
these settings in Sente’s preferences (see Advanced Window in 
Chapter 15).

Your results appear as a new Search  in your reference library, named 
after your search criteria; ctrl-click your Search to rename it.
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Z39.50 Searches
In addition to PubMed, Sente includes a plugin for searching via the 
Z39.50 protocols commonly used to access library catalogs and other 
data sources around the world.

Click Search on the toolbar, or choose File>New Search. From the 
popup list, select Z39.50 Data Sources and select a data source from the 
submenu. If you don’t see the one you want, select Other Z39.50 Data 
Sources to bring up a complete list of about 400 sources Sente knows 
about. To add or configure sources, or to control which sources appear in 
the Search menu, see Configuring Z39.50 Data Sources, below.

The Z39.50 window provides more options than PubMed for searching 
fields, such as begins with, ends with, equals, etc.

As with PubMed Searches, executing a Z39.50 Search produces a new 
Search folder in your reference library (see Viewing Results, above).
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Configuring Z39.50 Data Sources
Sente comes with a lengthy list of searchable Z39.50 data sources, but 
you can reconfigure any of them and add additional public and private 
sources. Select File>New Search>Z39.50 Data Sources>Other Z39.50 
Data Sources to bring up the Data Sources window.

Double-click in the columns to enter the Name, Hostname, Port, Collection 
name, and Encoding method (ANSEL or Latin-1). You can also enter a 
User Name and Password if required for access. Then with the new source 
highlighted, click Test Connection to Selected Data Source to see if 
Sente can access it based on the information you entered.

For any source, check the Fav? box to have it included in the 
File>New Search>Z39.50 Data Sources menu.
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About the Z39.50 Parameters

Once you’ve identified a Z39.50 database you want to add to 
Sente’s source list, you’ll need to obtain a handful of parameters 
from the data source’s owner (which is often a library). These are 
the above-mentioned host name, port number, collection name, and 
encoding method. Sometimes you can find this information on the 
library’s website; otherwise, you may need to contact the owner or 
administrator to get the information. 

Once you have the parameters in hand, click the + button on the 
Data Sources window and double-click in each field to enter the 
information (you can type anything you wish in the Name field).

If you test the connection and it fails, it could be you mistyped a 
parameter or the data source requires a user name and password 
(you may need to scroll right to find the User Name and Password 
columns).

Encoding
The character encoding method helps Sente display special 
characters. If characters with diacritical marks (like accents) aren’t 
showing up properly in a Search, switching the encoding method for 
the data source should correct the problem. Sente supports two 
encoding methods: ANSEL and Latin-1.
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Editing Searches (PubMed & Z39.50)
If you have an existing PubMed or Z39.50 Search based on complex 
criteria and want to perform a similar search of the same data source, 
you can copy those criteria and use them as a starting point for a new 
Search.

WARNING: Reexecuting a Search without copying it 
first can make you very unhappy because it deletes 
your Search and replaces it with a new one; if you've 
modified the contents of a Search by removing or 
editing its references, you could lose those 
modifications forever.

To copy and then edit an existing 
Search:

1. In the Library pane, option-drag 
an existing Search to a blank area in 
the box (or to another folder if you 
want to copy it there).

2. Double-click the copy you just 
created.

3. In the search box that appears, 
modify the criteria and click Execute 
Search.

You can also ctrl-click on a selected Search, choose Copy from the 
context menu, and then choose Edit>Paste to add it to your library.

Updating Searches (PubMed & Z39.50)
Each day, Sente automatically updates your Searches—assuming it can 
find the data source on the Internet—by downloading any new or 
updated items. If Sente encounters updated information for an existing 
reference that you have manually edited (see Chapter 4 - Editing and 
Annotating References), Sente will add the new information to the 
reference while preserving your edits. If Sente encounters an updated 
version of a reference you've deleted from PubMed Search, Sente will 
add the updated reference back to your Search. Any newly added 
reference will have an orange dot in the Reference Table.
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If you'd rather not wait for Sente to update your Searches, select 
Window>Update All Searches. On the other hand, if you need to 
reclaim some bandwidth while Sente is performing an automatic update, 
select Halt Running Searches to cancel the update process until the next 
scheduled update.

You can change how often Sente performs automatic 
updates, or disable the feature (see Advanced Window 
in Chapter 15).

Managing Searches in the Library Pane
ctrl–click on a Search icon to reveal a popup menu with Cut, Copy, 
Delete, and Rename commands.

You may drag (copy) references out of a Search (that is, out of the 
Reference Table with the Search selected) and into a Collection or 
Bibliography, but you cannot manually add references to a Search. 

Deleting References from Searches
If you delete a reference from a PubMed Search (use command-delete), 
future updates will ignore that reference as long as it remains unchanged 
in PubMed. Z39.50 databases, on the other hand, cannot keep track of 
references deleted from your Search; automatic updates will add back 
any references you have removed from a Z39.50 Search.

Setting Up Functional Hierarchies
Searches become much more powerful in the context of Collections and 
Filters; see Working with Collections in Chapter 8 for tips on nesting 
folders within your library. 
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7 • Filters

Although the Browser is good for "live" filtering, you can 
also save and maintain filtered results by creating Filters 
inside your Searches, Collections, Bibliographies, and even 
other Filters. And with the right hierarchies set up, you can 
even apply a single Filter to a group of Searches (see Working 

with Collections in Chapter 8).

A Filter never changes the contents of its parent, rather, it keeps tabs on 
what the parent contains and adjusts its own contents accordingly 
whenever the parent gets updated. 

Creating Filters
You can create as many different Filters as you want for a given parent 
folder.

1. Select a target folder in the Library pane; this can be any Search, 
Collection, Bibliography, or Filter in your reference library. 

2. Click Filter on the toolbar or select File>New Filter.

3. Set up your filtering criteria as you would for a new Search.

4. Click Apply to see the results of your Filter.

5. Modify your Filter if desired and then click OK to finish and save your 
Filter.

Your Filter will appear as a subfolder  under the selected target 
folder. Select the Filter to view its contents in the Reference Table.
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Filter Refresh Behavior
Filters do not update their contents while those contents are displayed in 
the Reference Table. For example, if you edit a displayed reference such 
that it no longer matches the filtering criteria—like changing its Rating—
it will not disappear from the Filter while you are editing it. Instead, click 
away from the Filter and then reselect it to refresh its contents.

Editing Filters
To modify an existing Filter:

1. Double-click a Filter in the Library pane, or select a Filter and click 
Get Info on the toolbar.

2. Modify the Filter dialog that appears.

3. Click OK to save the Filter and update its contents.

Copying Filters
If you want to apply the same Filter to another Search, Collection, 
Bibliography, or other Filter, option-drag the Filter to copy it to another 
folder (or simply drag to move it); the Filter will inherit its contents from 
its new parent. 

Managing Filters in the Library Pane
ctrl–click on a Filter icon to reveal a popup menu with Cut, Copy, 
Delete, and Rename commands.

Because Filters always inherit their contents from a parent folder, you 
cannot manually add or remove references from Filters, nor can Filters 
ever exist at the top level of your reference library.

The only thing you can manually place inside a Filter is another Filter. 

Deleting Filters
When you delete a Filter (use command-delete), you do not delete its 
references because these are retained in the Filter’s parent folder.
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Working With Filters

You can use Filters for a variety of specialized purposes:

Search Refinement—Rarely will your PubMed or Z39.50 Search 
extract exactly the references you need from the data source. 
Generally your Search will be broad enough to capture what you 
need, while bringing along additional unwanted references for the 
ride. The solution? Apply a refining Filter to the Search.

Classification Filters—One way to refine a Search (or any folder in 
your reference library) is to filter for a particular keyword, star rating, 
or status that you’ve assigned to references. For example, a “five-
star” Filter can take you straight to your most important references. 
You could achieve a similar result by ordering the Reference Table 
by Rating, but a Ratings Filter creates a simple, one-click solution.

Favorite Journals Filter—Use a Filter to create a “newsletter” of 
new articles from a few of your favorite journals. To do this, just 
create a Filter that only accepts references from your favorite 
publications, and copy the Filter to all of your Searches. In this way, 
you can view the parent Search to see everything, or just the Filter 
to see items from your favorite publications. Wondering what’s been 
published since your last check? Look for the orange dots in the 
Reference Table.

Multiple-Search Filters—Often a single Search won’t be enough to 
get what you want; you might need to run different set of search 
criteria against a data source, or you might need to search several 
different data sources. The solution is to place all of these similar 
Searches in a single Collection, and then apply a Filter to the 
Collection. See Working with Collections in Chapter 8 for an 
example.
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8 • Collections

To organize references manually within your library, you can 
create Collections and place references within them. A 
Collection may contain references copied from Searches and 
Filters, references imported from files, or references created 
manually within Sente. A Collection may also contain other 

Collections, Searches, Filters, and Bibliographies. 

Creating Collections
1. Click on a blank area in the Library 

pane to deselect all items, or select 
an existing Collection to add the 
new Collection as a subfolder.

2. Click Collection on the toolbar or 
select File>New Collection.

3. Immediately type a name to replace 
the default New Collection.

Adding References to Collections
To copy any references into a Collection, drag them from the Reference 
table and drop them onto a Collection icon . You can also ctrl-
click on references and choose Copy, then select the Collection and 
choose Edit>Paste.

Adding Folders to Collections
Drag a Search, Filter, Bibliography, or other Collection to your new 
Collection to move an entire folder; use option-drag to copy. 

When you place folders inside a parent Collection and then view the 
contents of the parent Collection in the Reference Table, you will see a 
unified, comprehensive list of all references derived from all subfolders, 
ignoring any duplicates.
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Managing Collections in the Library 
Pane
A Collection works like a standard folder. ctrl–click on a Collection 
icon to reveal a context menu with Cut, Copy, Delete, and Rename 
commands.

Deleting Collections
When you delete a Collection, everything it contains—including the 
contents of its subfolders—is deleted.
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Working with Collections

Collections aren’t just for getting your reference library organized. 
Because they inherit the contents of their subfolders, they can 
create unique views of your data. For example, if Search1 contains 
references A, B, and C, while Search2 contains references C, D, 
and E, what happens when you place both Searches into Collection 
Alpha? 

When you view Alpha, the Reference Table will contain references 
A, B, C, D, and E. This is because Collections create a unified view 
of their child folders, minus any duplicates (in this example, Alpha 
shows only one copy of reference C, even though C exists in both 
Searches). The result is the parent Alpha—conveniently—actually 
contains fewer total references than the sum of Search1 + Search2.

The main advantage here is that 
you can use a Collection to create 
a single, unified, and nonredundant 
view of a bunch of different 
Searches (or, for that matter, of 
other Collections).

To further take advantage of the 
unified view, you would then add a 
Filter to Collection Alpha. As shown 
at right, Alpha unifies three Searches, and the Favorites Filter is 
applied to Alpha—as a result, Favorites has created a single, filtered 
view of all Searches within Alpha.

This basic configuration saves you the trouble of copying Filters to 
multiple Searches and viewing possibly overlapping results 
individually.

Creating a New Reference
The only place where you can create a new reference from 
scratch is inside a Collection. You must select a Collection in 
your library to enable this feature.

1. Select a Collection in the Library box.

2. Click Reference on the toolbar, or choose File>New Reference.

3. In the empty Reference Editor that appears, choose a Reference 
Type and then go to work on the fields (see Reference Editor in 
Chapter 4).
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9 • Bibliographies

Sente uses a special kind of Bibliography folder in your 
reference library for generating rich text bibliographies. 
These formatted bibliographies are designed for pasting 
into any document, such as a reading list. You can control 

how your entries are structured through Sente’s customizable 
Bibliography Formats (see Chapter 12 - Custom Citation & Bibliography 
Formats).

Sente also provides advanced bibliography plugins for 
Microsoft Word and RedleX Mellel, similar to EndNote’s 
Cite While You Write feature (see Chapters 10 & 11). 
These plugins operate independently from the rich text 
bibliographies described in this chapter.

Creating Bibliographies
To prepare Sente for generating a rich text bibliography, you have to 
place references within a Bibliography in your reference library. A 
Bibliography is similar to a Collection (see Chapter 8 - Collections), except 
you can control the reference order.

1. Select File>New Bibliography. Sente 
will create an empty Bibliography 
folder in your reference library.

2. Type a name to replace New 
Bibliography.

3. Copy references into the Bibliography 
by dragging them from the Reference Table to the Bibliography folder. 
Drag an entire folder to move it into your Bibliography, or option-
drag to copy it. You can also copy folders and references using the 
context menu—just ctrl-click on a selection and choose Copy; 
then select your Bibliography and choose Edit>Paste.
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4. Select the Bibliography and use the Browser or Find box to pare 
down its visible contents in the Reference Table, if desired (see 
Chapter 3 - Viewing References). When you do this, only the 
references remaining visible in the Reference Table will be used to 
generate your bibliography.

Whenever a Bibliography is selected in your reference library, a preview 
pane appears below the Reference Table, showing how the formatted 
results will look.

5. From the menu above the preview pane choose a bibliography format 
or select Other Bibliography Formats to create a new custom 
format (see Chapter 12 - Custom Citation and Bibliography Formats).
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6. Click the headings in the Reference Table to sort the bibliography by 
Reference Type, Citation, Year, Author, or Article Title. To adjust the 
order manually, first order the table by clicking the Cit Ord column 
heading; then simply drag references up or down.

A bibliography format can override your reference order; (see Chapter 12 
- Custom Citation and Bibliography Formats).

7. When you are satisfied with the bibliography displayed in the 
bibliography box, click Place bibliography on clipboard to make it 
available for pasting into any text document.
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10 • Microsoft Word 
Bibliographies

Sente’s integration with Microsoft Word offers 
functionality similar to that provided by EndNote’s Cite 
While You Write feature. You can generate citations and 
bibliographies directly in Word documents by inserting 
citations for your references stored in Sente; Word can 

then generate a bibliography based on your inserted citations, again 
using reference information maintained in Sente. In this way, Sente 
controls the content and format of the document entries and keeps them 
up to date.
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Activating the Plugin
The Word plugin may already be installed and active if you chose 
activation when you first installed Sente. Choose Sente>Sente 
Preferences>Plugins to confirm that the MSWord plugin is installed.

You can install or reinstall  the MSWord plugin at any time 
(see MS Word in Chapter 15).

Sente Menu
When the MSWord plugin is active, a Sente menu appears in the Word 
Tools menu (or in the equivalent menu, depending on your language).

• Launch Sente opens Sente if it isn't running, or brings it to the front if 
it's running in the background. The other menu commands will also 
launch Sente automatically as part of their function.

• Insert Citation places a citation to a reference at the insertion point. 

• Edit Citation lets you manually edit any citation you’ve inserted.

• Group/Ungroup Citations toggles whether adjacent inserted citations 
are merged into a single citation. 

• Insert Bibliography creates a bibliography based on your inserted 
citations and places it at the insertion point.

• The Format selector shows which Sente bibliography format is 
determining the structure of your in-text citations and bibliography. 

• Refresh Document rebuilds all citations and the bibliography if, for 
example, you have moved or added citations.
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Inserting Citations & Bibliographies
1. In a Word document, place your insertion point where you would like 

to insert an in-text citation.

2. Select Tools>Sente>Insert Citation. Sente will automatically launch 
if it isn't running.

3. In the Reference Selector that appears, select one or more 
references.

4. Click OK. The citation will appear as a field structured according to 
the selected bibliography format. If you are citing multiple references, 
Word will merge the information into a single citation. To create or edit 
a bibliography format, see Chapter 12 - Custom Citation and 
Bibliography Formats.

5. Return to step 1 to add more citations to your document.

6. At any time you can select Tools>Sente>Insert Bibliography. Using 
the selected bibliography format, Word will build a bibliography from 
your inserted citations and place it at the insertion point.

Deleting a Citation
If you want to 
remove a citation 
from your 
document, be sure 
to highlight at least one text character before and after the citation field 
before deleting; otherwise the citation may reappear when you refresh 
the document.

Selecting a Bibliography Format
You can select a different bibliography format even after you have 
inserted citations and a bibliography. When you change the format via 
Tools>Sente>Format, Word updates your entries.
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Modifying a Format in Use
Word is quite forgiving regarding changes. You can even modify the 
selected bibliography format in Sente while your Word document is 
open; just choose Refresh Document to see the results.

Controlling Character and Paragraph Formatting
The first time you insert a citation into a document, Sente adds two new 
styles to your Word document’s style sheet called SenteCitation and 
SenteBibliography. These are automatically applied to in-text citations and 
bibliographies, respectively. By configuring these two styles (see Working 
with Styles, below), you can control the look of your citations and 
bibliographies.

All changes you make to the SenteCitation and SenteBibliography style will 
be preserved regardless of whether you add more citations, refresh the 
document, or change the bibliography format.

Editing Citations and Bibliography Entries Directly
To avoid creating unnecessary work you should always try to use Sente's 
Bibliography Format Editor combined with Word styles to achieve the 
results you want. Remember you can also go back into Sente and edit the 
original references if needed.

Editing Citations
If you need to manually edit an inserted citation—such as to append 
page numbers—click in the citation in your Word document and then 
select Tools>Sente>Edit Citation; your changes will stick even after 
refreshing the document.

WARNING: Do NOT edit your citations directly in your 
Word document because your changes will be lost 
when you refresh the document.

Editing Bibliography Entries
You can edit bibliography entries directly in your Word document. 
However, edits to bibliography fields are NOT retained after a document 
refresh. You may need to refresh if you add, delete, or move citations, or 
change the bibliography format—therefore direct editing of a 
bibliography entry is generally only useful as final step in manuscript 
preparation.
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Working with Styles

Although Sente’s Bibliography Formats can apply bold, italic, and 
underline to elements of your bibliography entry, all other aspects—
such as font, indentation, and margins—are determined by the 
SenteCitation and SenteBibliography styles in Word. Through these 
styles, you can set up global formatting rules to apply to all citations 
and bibliographies in your document.

Once you insert a citation into your document, you can access these 
styles by selecting Style from the Format menu.

Select one of the Sente styles in your Styles list and click Modify to 
configure its format. This allows you to, for example, set up a 
hanging indent for your generated bibliographies or set all of your 
citations to appear as superscript.

Disabling Proofing
To prevent Word from grammar- and spell-checking your citations 
and bibliography, do this for each style: in the Modify Style window, 
choose Format>Language and check Do not check spelling or 
grammar.
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11 • RedleX Mellel 
Bibliographies

Mellel 1.9.1 or higher will recognize Sente as a reference 
database if the two applications are running on the same 
computer. Mellel is an advanced word processor available 
from redlers.com.

Enabling the Mellel Plugin
The Mellel plugin is active in Sente by default; in Mellel however, you’ll 
need to specify Sente as the Bibliography Application:

1. In Mellel, choose Mellel>Preferences...

2. Select the Bibliography pane.

3. Select Sente from the Bibliography Application menu.
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Inserting Citations and Bibliographies
When Sente is running in the background, you can insert citations and 
generate bibliographies using Mellel’s standard bibliography commands. 
In this process, you’ll first insert unformatted citation tags into your 
original Mellel document and then generate a copy of the original with 
your formatted citations and bibliography. 

1. In Mellel’s Bibliography palette, click the Find in Reference Database 
button to insert a citation from Sente’s Reference Selector. You can 
also drag references directly from Sente and drop them onto your 
Mellel document (or use copy/paste).

Inserted citations appear as unformatted placeholders in your document. 
Citations inserted directly adjacent to each other will be merged into a 
single citation in your final document.

2. Insert the rest of your citations and finalize your manuscript.
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3. In the 
Bibliography 
palette, click 
the Scan 
Document 
button.

4. In the Scan Document dialog, select a Sente Bibliography Format 
(see Chapter 12 - Custom Citation and Bibliography Formats). This 
controls how your inserted citations and bibliography will appear 
when you generate a final copy.

5. Click Create Manuscript to generate a copy of your manuscript with 
formatted citations and an appended bibliography.

Although usually unnecessary, you may instead click Scan Document to 
verify inserted citations against their sources in Sente; Mellel will let you 
know if there are problems.

11: RedleX Mellel Bibliographies
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Editing Inserted Citations
If you double-click an inserted citation placeholder in your source 
manuscript, you can make certain edits to the field code.

• Insert \any text\ just before the # sign to append text to the 
citation, such as page numbers.

• Prepend a % sign to the beginning of the field code to show only the 
date in the citation tag (while leaving the bibliography entry 
unaffected).

• Check Exclude from Final Document to render the citation invisible 
while leaving its bibliography entry unaffected.

The Bibliography and Reference chapter of the Mellel Guide has more 
information about Mellel’s bibliography commands.
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12 • Custom Citation & 
Bibliography Formats

You can create and save your own custom Bibliography Formats in 
addition to those bundled with Sente. These formats give you precise 
control over the content and appearance of Sente, Word, and Mellel 
bibliographies (see Chapters 9-11). These formats also control the in-text 
citations inserted into Word and Mellel documents.

Your custom formats become available as menu choices for all 
bibliographies you create. They also become selectable for drag-and-drop 
formats and print formats (see Drag & Drop Export and Printing in 
Chapter 14), and for linked file naming formats (see Chapter 5 - Retrieving 
and Managing Full Text Files).

Constructing a Bibliography Format
To construct a new bibliography format, it is generally easiest to start 
with an existing format and modify it in the Format Editor:

1. Choose Window>Bibliography Formats.
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2. All existing formats are listed on the far left, and sample output for the 
selected format appears in the Sample Types pane. Select a format 
similar to what you want and click Duplicate.

3. Double-click the duplicate format to 
rename it.

4. Use the Display sample types 
menu to display formatted samples 
for all reference types you expect to 
appear in your bibliographies. You 
may set up different formatting rules 
for each reference type within your 
new Bibliography Format. 

5. Click Show/Hide Format Editor to 
show the Format Editor drawer.

6. Be sure the format you want to modify is still selected on the far left. 
Leave the Fav? box checked to keep the format selectable from 
Sente’s menus.
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As you modify the selected format in the Format Editor drawer, your 
changes are saved as you make them.

General Pane
This pane is where you configure formats for in-text citations that appear 
in Word and Mellel documents (see Chapters 10-11); the Rich Text Format 
options apply to only to bibliographies generated by Sente (see Chapter 9 - 
Bibliographies).

Order bib. by:
• Occurrence in collection replicates the order in the Bibliography 

folder for Sente’s rich text output; in Word and Mellel, bibliography 
entries appear in same order as their citations in the document. 

• First author surname overrides the reference order in the 
Bibliography folder and the order of inserted citations in Word and 
Mellel documents.

• Tag value also overrides other ordering in favor of citation tags 
leading the bibliography entries. For example, you would want to 
order by Tag value if your format will reproduce the in-text citation 
tag, such as (Smith, 1997), at the beginning of each bibliography 
entry—this way the entries can be ordered by this initial citation tag. 
You can insert tags when you set up the Bibliography Entries (see 
Setting Up the Element Sequence later in this chapter).

12: Custom Bibliography Formats
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Tag style in bib:
If you are including citation tags within your bibliography entries, you 
can configure them as sequential numbers or author-year combinations. 
This setting does not affect the look of your in-text citations.

In-Text Citations
In-text citations 
only apply to 
bibliographies 
generated in Word 
or Mellel (see 
Chapters 10 and 11). Your in-text citation tag can be a number or author-
year combination. If you choose Sequential Numbers for your tag style, 
check Use numeric ranges if you would like multiple-reference citations to 
appear as (1-3) instead of (1, 2, 3).

Add any desired spaces or punctuation in the Prepend and Append fields; 
the Separator appears between entries in multiple-reference citations.

To view the results of your selections, insert a few citations into a Word 
or Mellel document in the current format and refresh/regenerate the 
document as you adjust the format.

Rich Text Format
Rich text format options only apply to bibliographies generated by Sente 
(see Chapter 9 - Bibliographies) and to drag-and-drop and print formats.
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Bibliography Entries Pane
For each reference type in your format, you configure the bibliography 
entry by stringing together a sequence of Elements and specifying rules 
for applying punctuation and spacing around each Element. As you 
assemble Elements for each reference type, you can review sample 
output in the Sample Types pane.

Setting up the 
Element Sequence
Choose a reference 
type from the 
uppermost menu. If 
you don’t see the one 
you want, make sure 
it’s checked in the 
Display Sample Types 
menu. 

Add items to the 
Elements list in the 
order you want them 
to appear in the 
bibliography entry. To 
do this, select an 
existing Element in 
the list and then use 
the Element Type menu 
to change it; to add a 
new Element, click + 
to add the Volume 
Element by default, and then use the Element Type menu to change the 
new Volume Element to the one you want. Use the Up and Down buttons 
to arrange Elements in the correct sequence.

In addition to the standard bibliographic Elements, you can include the 
Abstract and Notes. Other unusual Elements include:

• Authors, Compilers, Editors, and Translators are all types of 
authors, or author roles, that may be specified in a reference (see 
Reference Editor in Chapter 4). 

• Static text allows you to insert any fixed text.
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• If you want to include the in-text citation tag and order the 
bibliography entries accordingly, be sure place the Tag Element at 
the top of the Elements list.

Viewing Sample Output
When your Elements list is complete, select any item in the list. In the 
Sample Types pane, the sample output for that Element is highlighted 
yellow.

Configuring Each Element
Immediately below the 
Element Type menu 
some options specific to 
the selected Element 
may appear. For 
example, there are a 
number of ways to 
configure the Authors 
Element. Move down 
the Elements list to 
configure each one, and 
review your changes in 
the Sample Types pane.

The area below the 
Element-specific 
options contains a set 
of static options that 
can also be individually 
applied to each 
Element. These options 
are for cleaning up any 
punctuation that may 
come along with an 
Element, and for 
adding font treatments.
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• Remove trailing punctuation characters, when checked, will strip all 
occurrences of the trailing punctuation you specify. 
For example, if you enter .; in this field, all trailing periods and 
semicolons will be stripped from the selected Element. 

• Add trailing punctuation character, when checked, will append 
punctuation to the Element after any specified trailing punctuation has 
been removed.

• ...unless data ends with any of, when checked, will override the 
previous field when the specified trailing punctuation still exists after 
any specified trailing punctuation has been removed.

• Prepend and Append adds any characters after any checked 
operations above have been performed. Type a space to add a space, 
\n to insert a line break, and \t to insert a tab.

The Italics, Bold, and Underline treatments at the bottom of the window 
will override any conflicting treatments specified in your Word or Mellel 
style sheet.
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Working With Punctuation

It is often important to 
correct trailing 
punctuation for 
Elements that contain 
a publication title or 
article title. In these 
cases, the example 
shown here often 
works. 

This format first strips 
all periods and 
semicolons from the 
end of the Publication 
Title, then adds back a 
period—unless the 
Publication Title 
already ends in a 
question mark. Finally, 
the format puts a 
space at the end.

The result is that 
every Publication Title 
will end with either a period or a question mark, followed by a space.

Configuring Other Reference Types
When you have finished setting up the Elements for your first reference 
type, select the next type (such as Book) and then use the Copy menu to 
copy the setup from the first type—usually, only minor changes will be 
needed to adapt your format for each reference type.
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Advanced Pane
In the Advanced pane, you can prepend or append the entire 
bibliography with any text. You can also customize the text used for 
“and” and “et al” in citations—for example, you can have & appear 
instead of the default and. 

Sharing Your Custom Formats
You can share your Bibliography Formats with other Sente users. From 
the Bibliography Formats window, drag the format name to the desktop. 
Sente will create a .bibstyle file which another user can then drag into 
their own format name list. You can also drag formats directly from 
Sente to an email message; the .bibstyle file will become an attachment.

Downloading New Formats
From time to time, new formats may become available for downloading 
from ThirdStreetSoftware.com. Generally these new formats will be 
bundled in an upcoming release of Sente. If you choose to download 
a .bibstyle file in advance of an update, simply drag the file to your 
format name list in the Bibliography Formats window.

12: Custom Bibliography Formats
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13 • Automated Reference 
Processing

Sente includes five plugins that can apply specific processing actions to 
any selected references These include various methods for full text 
retrieval (see Full Text Retrieval in Chapter 5) and adding Amazon.com 
cover art to the reference’s Preview pane. You can access these functions 
by selecting Edit>Perform: 

The upper part of the submenu includes any custom scripts (see below) 
you may have created to perform multiple actions; in the example above, 
DOI + PubMed Linkout is a custom script.

Custom Processing Scripts
You can create a single command, or script, that invokes multiple 
reference-processing actions in a particular sequence. To create or edit a 
custom script:

1. Select Edit>Perform>Create/Edit Scripts...

2. In the Reference Processor Script Editor window, click the + button 
below the Script Name box to create a new script, or select an 
existing script to edit.

3. In the Name box, enter the name as you would like it to appear on the 
Perform submenu.

4. Click the + menu below the Steps box to add an action to the script; 
repeat to add additional actions in the order in which you want them 
performed.
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If you would like to assign a keyboard shortcut to your custom script, 
take note of the exact name of the script as it appears in the Perform 
submenu and then assign a shortcut using the Mac OS System Preferences 
as described in Appendix - Keyboard Shortcuts.
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14 • Importing, Exporting and 
Printing

Importing Data
Sente can read and import references from the following file formats:

• BibTeX

• EndNote 7 XML

• EndNote 8 XML

• EndNote 9 XML

• MARC21

• PubMed/Medline XML

• Refer (Generic)

• Refer (EndNote)

• Reference Manager (RIS)

• TaggedRecord

• Web of Science

When you import data, Sente will place the references in a new Collection 
using the source file name as the Collection name. To import data:

1. Highlight an existing folder in your reference library if you want to 
import references as a new subfolder, or click on a blank area within 
the Library pane to create a new top-level Collection with the import.

2. Select File>Import.

3. Choose a file in one of the accepted formats and click Open.
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Exporting Data
You can export an entire folder from your reference library or selected 
references from the Reference Table. Sente can save your references as:

• BibTeX

• BibTeX (Unicode)

• EndNote 9 XML

• Refer (EndNote)

• Refer (Generic)

• Web of Science

The two BibTeX options treat special characters differently; standard 
BibTeX uses complex escape sequences to represent special characters, 
whereas BibTeX (Unicode) substitutes unicode for the escape sequences.

To export references:

1. Select a Search, Filter, Collection, or Bibliography in the Library pane.

2. If you don't want to export the entire folder, select the items you want 
included in the export in the Reference Table.

3. Select File>Export.

4. Select an export type (All references in selected collection will export 
the entire folder regardless of what is selected in the Reference 
Table) and file format.

5. Choose a file name and location, then click Export. 

Drag and Drop Export
You can also export references simply by dragging them out of the 
Reference Table and dropping them into a text document. They will 
appear as formatted bibliography entries. Similarly, you can use the Edit 
menu to cut or copy references and paste them (as formatted 
bibliographies) into other applications.

You can specify any Bibliography Format for Drag and 
Drop export (see Drag & Drop in Chapter 15).
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Printing
Sente can print a folder from your reference library (or any 
selected references) as a formatted bibliography. You can 
select a Bibliography Format (see Chapter 12 - Custom Citation 
and Bibliography Formats) in the print dialog.

1. Select a folder in the Library pane or references in the Reference 
Table.

2. Select File>Print or click Print on the toolbar.

3. In the Print window, select Sente from the third menu.

4. Choose a Report Style (a Bibliography Format).

5. Click Preview—Sente can create a formidable print job if you 
selected an entire folder, so previewing is always a good idea.

14: Importing, Exporting, & Printing
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15 • Configuring Sente

Sente’s interface is highly customizable. Largely through the Preferences 
window you can control the content of menus, configure keyboard 
shortcuts, and tweak Sente’s behavior.

Select Sente>Sente Preferences... (or press command-,) to access the 
Preferences window.

 Customize Window

Ref Types
Reference Type is an important parameter for every reference; this table 
lists all of the types that Sente keeps track of. The abbreviations appear in 
the Reference Table and the full type names appear in the Reference 
Editor and in the Bibliography Format Editor. You can edit the Abbrev 
and Reference Type columns; Internal Type is used for tracking purposes 
and cannot be edited.
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Ref Status
Each reference in your library can be assigned a Status and, if desired, a 
text color to indicate the Status in the Reference Table. You can create any 
number of named Statuses and up to nine keyboard shortcuts for 
assigning them. The shortcut format for Status is 
option-command-(0-9), where option-command-0 means no 
assigned Status.

Click the Text color box to select a color indicator for any status, and 
double-click in the table to change names and descriptions.
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Fields
The Field Name list lets you add custom text fields to the Reference 
Editor; any fields you define here will become globally available in the 
Reference Editor.

Custom fields may get added to this list automatically when you import 
references from files.
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Keywords
Your custom Keyword list determines what is available in the keyword 
assignment menus in the Reference Editor, the Details Drawer, and in 
popup menus. You can create any number of Keywords (or keyphrases) 
and up to nine keyboard shortcuts for assigning them. The shortcut 
format for Keywords is command-(0-9).

When you delete a keyword from this list, you are only removing it from 
Sente’s keyword-assignment menus; any references to which the 
keyword is already assigned will retain the keyword.
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Auto Links
When downloading a reference, Sente automatically finds special 
identifiers that it can to use to generate related URLs. For example, a 
PubMed reference typically contains a PubMed ID. When Sente inserts 
that ID into the PubMed URL template, it creates a link to information 
related to that reference. You can teach Sente to extract other kinds of IDs 
and use them to automatically generate links.

Sente comes with a few existing templates; click + to create a new one.

Double-click in the columns to enter information. The Label is the name 
of the link as it appears in Sente's menus. The ID Authority is the name of 
the ID; Sente uses this name to fish the ID from the reference data. The 
URL template contains the string {id} where Sente will insert the ID you 
specified, if it exists.

Use the Move Up and Move Down buttons to change the order of links 
appearing in Sente’s menus.

15: Configuring Sente

95



 Appearance Window

Reference Table
You can choose to show and hide columns in the Reference Table in 
Sente’s main window; showing a column gives you the ability to order 
your references by that column.
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Fonts
You can enlarge the font display in areas of the Sente’s main window.
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 Bibliography Window

Drag & Drop
You can choose a Bibliography Format (see Chapter 12 - Custom Citation & 
Bibliography Formats) to use as a Drag & Drop / Copy & Paste format (see 
Drag & Drop Export in Chapter 14). 

Mellel
The Mellel pane provides information about the Mellel word processor 
plugin; at this time there are no user settings in this pane.
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MS Word
To install the MSWord plugin (see Chapter 10 - Microsoft Word 
Bibliographies), click Automatically install/update the MS Word 
integration file.

In most cases, this is all you need to do—Sente will place a file called 
SenteMenus.dot in the Word Startup folder and will notify you that 
installation was successful. You may need to relaunch Word for the 
change to take effect.

Sente may report an installation failure if it cannot locate the Word 
Startup folder—if Word is not installed locally or if the folder has been 
moved, renamed, or redesignated. If installation fails:

1. Click Manually place the MS Word integration file.

2. Navigate to whichever folder is designated the startup folder for Word 
and select it (see your Microsoft Word documentation for information 
on specifying a startup folder).

3. Click Save template here.
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Title Case
This list allows to you create exceptions to the Force Title Case rule 
applied to Elements in Bibliography Formats (see Bibliography Entries 
Pane in Chapter 12).
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 Plugins Window

This window lists all installed plugins and allows you deactivate any 
that you don’t need. Among Sente’s standard plugin set, the Z39.50 Data 
Source (see Configuring Z39.50 Data Sources in Chapter 6), DOI/Handle, 
and Google (see Full Text Retrieval in Chapter 5) plugins are configurable 
via the Configure Selected Plugin button.

Installing Additional Plugins
From time to time, new plugins may be made available from 
ThirdStreetSoftware.com. To install a plugin file, quit Sente, select the Sente 
application file, and then chose File>Get Info from the Mac OS Finder. 
In the Plug-ins section of the Info window, click the Add... button.

If you are familiar with Objective-C you can create your own plugins—
either for yourself or to share with the Sente user community. Contact 
Third Street Software for instructions.

15: Configuring Sente
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 Link Window

Check the Sente should manage documents linked to references checkbox to 
activate Sente’s automated file management feature. With link 
management enabled, Sente will automatically rename and organize files 
as you link them to references.

After making changes, click Apply to Previously Linked Files if you 
want your existing linked files and folders updated to reflect your new 
preferences; otherwise, your changes will only apply to links you create 
subsequently and any previously linked files will remain untouched. 

For information on how to use the file management feature, see
Chapter 5 - Retrieving & Managing Full Text Files.
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 Advanced Window

Use the Advanced window to adjust Sente’s background behavior. 

By default, Sente updates all of your Searches daily, confirms when it 
finds more than 100 references (thus allowing you to refine your Search 
before downloading the results), cuts off downloads at 1000 references, 
and removes the orange dot (unviewed indicator) after you look at a 
reference for one second.

WARNING: Be careful about raising the search results 
limit above the default 1000 references; downloading 
very large Searches will significantly impact 
performance.

Sente may also get bogged down if you combine several folders in your 
Library to create a single folder with, for example, 50,000 references; 
Sente warns you any time it tries to load a folder with more than 9999 
items.

You can also change the location of your reference library. By default 
Sente stores your references in ~/Library/Sente. There are two reasons you 
might want to change this location. First, if your user folder isn't 
automatically backed up, you might want to store your reference data 
elsewhere. Second, if you'd like to access your data from multiple 
locations, you can put Sente's data on a network drive.
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 Registration Window

The Registration pane allows you to view and enter registration 
information. Although you may use the same Order Code/License Key 
on multiple computers, each computer has unique Authorization Codes. 
Therefore if you are upgrading to a new computer, you should 
de-authorize Sente on the old computer before authorizing Sente on the 
new machine.

Sente 4.0

104



Toolbar
Click Customize on the toolbar (or select View>Configure 
Toolbar) to add, remove, and arrange items on your toolbar.

Journal Titles
Sente automatically remembers the journal titles it encounters when it 
downloads reference data. Sente uses its journal list to provide you with 
choices in the Reference Editor and to write out bibliographies. You can 
edit any journal title in the list as well as add your own titles.

Select Window>Journals. Edit any titles, abbreviations, and ISSNs. You 
can also add and delete titles.

By default Sente stores the same text for both the title and abbreviation. 
This comes into play when you are creating Bibliography Formats, which 
can use either full titles or abbreviations. By editing the journal list you 
can educate Sente regarding which is which so that a format calling for 
abbreviations, for example, becomes meaningful.
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Appendix • Keyboard Shortcuts

Action Shortcut

Previous/Next Item in List up/down arrow

Next Unviewed Reference spacebar

Select Multiple Items in List command-click

Select Block of Items in List shift-click

Delete Reference or Library Folder command-delete

Click and Type to Browse click browser list heading

Assign Custom Keyword command-[1-9]

Assign Status option-command-[0-9]

Assign Rating ctrl-command-[0-5]

Open Default Linked File/URL shift-command-F

Move Library Folder drag

Copy Library Folder option-drag

Copy Reference from Reference Table to 
Library Folder drag

Open Preferences Window command-,

Open Spotlight Window option-command-
spacebar

Context Menu for Selected Library 
Folder: 
Cut/Copy/Delete/Get Info/Rename

ctrl-click folder

Context Menu for Selected References:
Cut/Copy/Get Info/Assign Keyword/
Set to Viewed/Set to Not Viewed/
Specify Full Text File

ctrl-click reference

Wildcard Character in PubMed Search *
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Customizing Keyboard Shortcuts
Mac OS X provides the ability to assign or reassign any keyboard 
combination to any menu selection in any application. To assign 
shortcuts to an option accessible from Sente’s main menu bar:

1. Select System Preferences... from the Apple menu.

2. In the Hardware row, click Keyboard & Mouse.

3. Click Keyboard Shortcuts.

4. Click the + button to add an application.

5. Select Sente from the Application: menu.

6. Enter the Menu Title and a valid Keyboard Shortcut, then click Add. 
Be sure the menu title you enter exactly matches the name of the 
menu (or submenu) option as it appears in Sente. For example, to 
create a shortcut for Edit>Perform>Locate full text using Google, 
simply enter Locate full text using Google in the Menu Title 
box.

If Sente was running when you assigned the shortcut, you’ll need to 
quite and relaunch Sente to see your changes. 
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